• Welcome to Tekno RC Forums! Are you a Tekno RC fan? If so you're in luck as you've have arrived to the biggest and best Tekno RC community.

    Come join our community and ask your questions, show off your Tekno RCs and share your experience!

MT410 ESC mounting plate - wonky

aclewett

Member
Messages
7
Reaction score
0
The ESC mounting plate on the MT410 does not seem to fit properly. You can see in the picture that the screw fitting on the mudguard underneath circled in the picture seems to make the plate kick up slightly. Is this normal? Everything else in the kit is so well designed it's making me doubt myself...
20201119_090139.jpg
20201119_090237.jpg
20201119_090139.jpg
20201119_090237.jpg
20201119_090139.jpg
20201119_090237.jpg
 

MAVERICK

Premium Member
Supporting Member
Messages
129
Reaction score
102
Location
Troy Illinois
Tekno RC's
  1. EB48
I also had that issue on my eb48.4 I just notched it out so the plate would sit flat
 

aclewett

Member
Messages
7
Reaction score
0
I also had that issue on my eb48.4 I just notched it out so the plate would sit flat
Thanks for replying. Seems slightly oddly designed when everything else has been spot on.
 

TBuggy

Well-known member
TF Excellence Award
Supporting Member
Build Thread Contributor
Messages
1,165
Reaction score
821
Location
Seattle
Tekno RC's
  1. EB410
  2. EB48
  3. ET410
  4. SCT410
This part should sit flat without any modifications to it.
Do you have the o-rings glued to all 3 points?
Screen Shot 2020-11-19 at 7.33.50 AM.png


I wonder if the side pods have slightly changed. I have never had this issue on my buggy or SCT.
 

aclewett

Member
Messages
7
Reaction score
0
This part should sit flat without any modifications to it.
Do you have the o-rings glued to all 3 points?
View attachment 5749

I wonder if the side pods have slightly changed. I have never had this issue on my buggy or SCT.
Yes I put the o rings on. I think its okay actually just expected it to be designed to be more flush. Thanks for responding.
 

MAVERICK

Premium Member
Supporting Member
Messages
129
Reaction score
102
Location
Troy Illinois
Tekno RC's
  1. EB48
This part should sit flat without any modifications to it.
Do you have the o-rings glued to all 3 points?
View attachment 5749

I wonder if the side pods have slightly changed. I have never had this issue on my buggy or SCT.
I have 2 eb48.4’s and I had this issue on both. Not a big deal for me just odd due to the quality of the fitment on the rest of the kit. My et48.3 had no issues
 
Similar threads

Similar threads

Recent Popular Liked

Top